Difference: AlienInstallSourceFlorianUhlig (1 vs. 5)

Revision 5
22 Sep 2011 - Main.FlorianUhlig
Line: 1 to 1
 
META TOPICPARENT name="AlienFlorianUhlig"

HowTo install AliEn from source

Line: 47 to 47
 

  • perl on the lxcbm in Dubna has a problem. Somehow on has to change the following file ./ext/IO/poll.h.
    • In line 14: #include <poll.h> -> #include <sys/poll.h>
Changed:
<
<
  • httpd on lxcbm in Dubna uses somehow the wrong libtool which breaks with an error. To use the correct libtool the file /build/config_vars.mk has to be changed:
    • In line 149: /usr/lib64/apr-1/build/libtool -> /usr/bin/libtool
    • completely get ride of the portal directory
>
>
  • httpd on lxcbm in Dubna uses somehow the wrong libtool which breaks with an error. To use the correct libtool change the Makefile in apps/portal/httpd .
    • Add --with-included-apr to CONFIGURE_ARGS.
 

-- FlorianUhlig - 13 Nov 2009
Revision 4
20 Sep 2011 - Main.FlorianUhlig
Line: 1 to 1
 
META TOPICPARENT name="AlienFlorianUhlig"

HowTo install AliEn from source

Line: 34 to 34
 
find . -name Makefile -exec sed -e 's#apps/gcc/gcc##g' -i "{}" ";"
Added:
>
>
  • Remove the gcc subdirectory from apps/Makefile
 
  • Configure everything with the path to the native compiler
%CODE{"bash"}% ./configure --with-gcc-path= --prefix= --with-globus-flavor=gcc64dbg
Revision 3
16 Feb 2011 - Main.FlorianUhlig
Line: 1 to 1
 
META TOPICPARENT name="AlienFlorianUhlig"

HowTo install AliEn from source

Line: 28 to 28
 

If you prefer to use your own compiler, you have to do:
Added:
>
>
  • Be careful that no link to the old alien version is in your environment. This can cause strange problems. You can do a env and grep for the path of your alien installation.
 
  • change the Makefile in apps subdirectory. Exclude in this file "gcc" from the directories listed in DIRS (Since version v217 this is already done while applying the patch file)
  • Delete dependencies tp apps/gcc/gcc in all other packages. this can be done by runing the following command in the main directory of antidot.
%CODE{"bash"}%
Revision 2
16 Feb 2011 - Main.FlorianUhlig
Line: 1 to 1
 
META TOPICPARENT name="AlienFlorianUhlig"

HowTo install AliEn from source

Line: 43 to 43
 

  • Authentication on 64 with gcc. There is a problem with the openssh delivered with globus on 64 bit systems with gcc 4. The problem does not show up with compiler version gcc 3. The problem is described at http://bugzilla.globus.org/globus/show_bug.cgi?id=4617 . The solution for this systems is to compile globus with debug options flavor=gcc64dbg instead of gcc64).
Added:
>
>
  • perl on the lxcbm in Dubna has a problem. Somehow on has to change the following file ./ext/IO/poll.h.
    • In line 14: #include <poll.h> -> #include <sys/poll.h>
  • httpd on lxcbm in Dubna uses somehow the wrong libtool which breaks with an error. To use the correct libtool the file /build/config_vars.mk has to be changed:
    • In line 149: /usr/lib64/apr-1/build/libtool -> /usr/bin/libtool
    • completely get ride of the portal directory
 

-- FlorianUhlig - 13 Nov 2009
 
This site is powered by FoswikiCopyright © by the contributing authors. All material on this collaboration platform is the property of the contributing authors.
Ideas, requests, problems regarding CBM Wiki? Send feedback
Imprint (in German)
Privacy Policy (in German)